DELETE Elections and the Economy - Premiere Elements

From Help Wiki


General help for Adobe Premire Elements.

Create A New Project

  1. Launch Premiere Elements from the Dock.
  2. Go to File > New > Project
  3. Name the project descriptively (with your name)
  4. Select a location to Save In by clicking Browse
  5. Select the Storage icon on the left.
  6. Click the New Folder button on the bottom and label the new folder with your name.
  7. Click Choose.
  8. Click Change Settings and select the DV folder.
    • Based on your source footage select either Standard, or Widescreen and click OK.
  9. Click OK to finalize settings.

Editing Modes

There are two different modes to edit content: Timeline and Sceneline. It is recommended to use the Timeline view because of more available features.

Trimming Source Clips in the Preview Monitor

Remove unwanted footage from source clips.

  1. Double click on a video clip in the Project panel.
  2. A preview window appears of the video with playback controls and handles for setting in and out points.
  3. Adjust the handles or place the playhead and press I to set an in point, or O to set the out point.
    • The in and out points can always be adjusted to reveal the full length of the clip.

Insert Edit

Shifts other clips in the timeline out of the way.

  • Click and drag a clip from the Project panel into a video track in the timeline.
  • Release the mouse when an icon with a right pointing arrow appears.
  • Other audio/video clips will move forward or backward out of the way.

Overlay Edit

Covers up one clip with another-

  • Click and drag clips over other clip into the timeline by pressing and holding the command key.
  • Release the mouse when a centered arrow icon appears.

Snapping

When moving clips in the timeline this will align to other objects (playhead, other clips, markers, etc) and prevent gaps.

  • From the top menu Timeline > Snap, or press S.

Adding Transitions

Apply transitions in the finishing stages of editing. Transitions must be shorter than the clip length.

  1. In the Edit tab select Transitions.
  2. Click and drag a transition over a clip, release the mouse when a color overlay appears.
  3. To edit the transition double click on the icon.
  4. To preview the actual clips press the eyeball button and make adjustments using the value sliders on either side, adjust the length with the Duration slider.
  5. To apply changes click Done.
  6. Delete a transition by selecting it and pressing delete.

Playback & Rendering

  • To get a rough preview of content press the Play button in the Monitor panel, or press the Spacebar.
  • When red lines appear in the timeline over footage, or playback is slow/jerky, grab the Work Area Bar near the start of the timeline and span it over all content. From the top menu, Timeline > Render Work Areaand all content will be processed, or rendered, for improved playback.
  • Press the Full Screen button on the top right to view content fully. Press esc to exit.

Adding Titles

Included in Premiere Elements are themed titles through the Edit tab. It is recommended to create your own titles through the Monitor window on the bottom right T icon. Please spell check content in a text editor.

  1. Click in the text field to edit content.
  2. In the right hand edit screen change formatting properties just like a text editor.
  3. Use the edit tools to change on-screen position, create shapes, and change color.
  4. Refine positioning adjustments layering from the top Title menu.
  5. Keep all text content within the inner-most guide frame to ensure content will remain visible on any viewing device.
  6. To apply changes click Done the bottom right of the Edit tab screen.
  7. The title will appear as a purple video clip. Drag this over another clip to have it superimposed, or have it over black.
  8. Adjust the duration by dragging on either side of clip to shorten or lengthen.
  9. Make adjustments by double clicking on the title clip in the timeline to re-edit.

Scrolling Credits

  1. Create a title.
  2. Use return to make sure each line of text fits horizontally on screen.
  3. From the top menu, Titles > Roll/Crawl Options....
  4. In the dialog that appears change the type to a roll and click OK to apply changes.

Sharing

Export to Tape

  1. In the Tasks panel select the Share tab.
  2. Select Tape Record to DV Tape.
  3. Make sure to pre-cue the tape after existing footage, or use a brand new cassette.
  4. Check the box Activate Recording Device & include Preroll of at least 150 frames (5 seconds).
  5. Click Record to start recording.

Export as Computer file

  1. Select to share to Computer.
  2. Select the Quicktime format from the list.
  3. In the Preset menu choose:
    • NTSC DV, or NTSC DV 16:9
  4. Name the file descriptively - with your name.
  5. Choose to save into your folder.
  6. Click Save on the bottom right. It may take a few minutes to process the exported file.
  7. After exporting is completed, quite Premiere Elements and watch through your final piece in Quicktime player.