DELETE Mediaworks- Premiere Pro Part 2

From Help Wiki

Keyframes can be used to change values over time for various effects.

A keyframe marks the point in time where you specify a value, such as spatial position, opacity, or audio volume. Values between keyframes are interpolated. To create a change in a property over time, you set at least two keyframes—one keyframe for the value at the beginning of the change, and another keyframe for the value at the end of the change.

Effects Control Panel

View Keyframes

  1. Select a clip in the Timeline panel.
  2. Click on the Effects Controls panel.
    • If necessary, click the Show/Hide Timeline View button in the Effect Controls panel to show the effects timeline.
    • Show Pp show timeline view.png ----- Hide Pp hide timeline view.png
  3. Click the triangle to the left of the effect name to expand the effect you want to view. Any existing keyframes will display in the Effect Controls timeline.
  4. To view the Value and Velocity graphs of an effect property, click the triangle next to the Toggle Animation icon PP WatchOff N.png.PP effects conntrol.png

Navigate Keyframes

  • The left-pointing arrow moves the current-time indicator to the previous keyframe.
  • The right-pointing arrow moves the current-time indicator to the next keyframe.
  • Shift-drag the Playhead to snap to a keyframe.

Add Keyframes

  1. Click the triangle to expand the effect property and display its Value and Velocity graphs.
  2. Move the playhead to the point in time where you want to add a keyframe.
  3. Click the Add/Remove Keyframe button PP KeyNav N.png and then adjust the effect property’s value.
    • Adjusting the controls for an effect’s property will automatically create a keyframe at the current time if there is no keyframe.
  4. Repeat as needed to add keyframes and adjust the effect property.

Select Keyframes

  • Click on a keyframe to select it.
  • Shift-click to select multiple contiguous or noncontiguous keyframes.
  • Click and drag to select multiple contiguous keyframes.
  • Click the layer property name to select all keyframes for a property.

Delete Keyframes

  • Select one or more keyframes and choose Edit > Clear. You can also press Delete.
  • Navigate the playhead to a keyframe and click the Add/Remove Keyframe button PP KeyNav N.png.
  • To delete all keyframes for an effect property, click the Toggle Animation button PP WatchOff N.png to the left of the name of the effect or property. When prompted to confirm your decision, click OK.

Modify Keyframe Values

  • Click and drag a keyframe in the Value graph.
  • Put the playhead over the keyframe to be modified and adjust the property value by clicking and dragging the number left or right.


Timeline Panel

View Keyframes

Time Display Settings is the Wrench icon in the top left of the Timelines panel

  • Expand the view of a track, if necessary, by clicking the Wrench icon and select Expand All tracks
  • Show video keyframes by clicking the Wrench icon and select Show Video Keyframes
  • Show audio keyframes by clicking the Wrench icon and select Show Audio Keyframes
  • For a video track, right-click on a video clip and select Show Clip Keyframes and select
    • Motion
    • Opacity
    • Time Remapping
  • For an audio track, right-click on a video clip and select Show Clip Keyframes and select
    • Volume
    • Channel Volume
    • 'Panner
  • Note: If no keyframes exist on the track, the rubber band appears as a straight horizontal line across the entire track.

Navigate Keyframes

  • The left-pointing arrow moves the current-time indicator to the previous keyframe.
  • The right-pointing arrow moves the current-time indicator to the next keyframe.

Add Keyframes

  • Move the playhead to the point in time where you want to add a keyframe and click the Add/Remove Keyframe PP KeyNav N.png button.
  • With the Pen tool click on the keyframe graph. You can add a keyframe anywhere on a graph using Pen tool. It’s not necessary to position the playhead.

Select Keyframes

  • Use the Selection tool or the Pen tool and click on any Keyframe.
  • To select multiple keyframes, Shift-click with the Selection tool or the Pen tool to select multiple contiguous or noncontiguous keyframes.
    • Note: When you position the Selection or Pen tool over a keyframe, the pointer appears with a Keyframe icon.
    • Pp pointer keyframe.png
  • To select multiple keyframes by dragging use the Pen tool to draw a marquee selection box around the keyframes. Shift-drag to add more keyframes to an existing selection.

Delete Keyframes

  • Select one or more keyframes and choose Edit > Clear. You can also press Delete.
  • Navigate the playhead to the keyframe and click the Add/Remove Keyframe button.

Modify Keyframes

  1. Use the Selection or Pen tool to select one or more Keyframes.
  2. Position the Selection or Pen tool over a keyframe or keyframe segment.
  3. Drag a keyframe or segment up or down to change the value. As you drag, a tool tip indicates the current value. If no keyframes are present, dragging adjusts the value for the entire clip or track.
  4. Drag a keyframe left or right to change the time location of the keyframe. As you drag, a tool tip indicates the current time. If you move a keyframe onto another keyframe, the new keyframe replaces the old one.
    • The Value and Velocity graphs in the Effect Controls panel will show changes made to keyframes in a Timeline panel.


Keyframe Interpolation

Interpolation Types

In the Effects Control panel or the Timeline panel right click on a keyframe marker to chage the interpolation method.

  • Linear: Creates a uniform rate of change between keyframes.
  • Bezier: Lets you manually adjust the shape of the graph, and the rate of change, on either side of a keyframe. You can create very smooth changes using this method.
  • Auto Bezier: Creates a smooth rate of change through a keyframe. As you change a keyframe’s value, the Auto Bezier direction handles change to maintain a smooth transition between keyframes.
  • Continuous Bezier: Creates a smooth rate of change through a keyframe. However, unlike the Auto Bezier interpolation method, Continuous Bezier lets you adjust direction handles manually. As you change the shape of a graph on one side of a keyframe, the shape on the other side of the keyframe changes to maintain a smooth transition.
  • Hold: Changes a property value without gradual transition (sudden effect changes). The graph following a keyframe with the Hold interpolation applied appears as a horizontal straight line.
  • Ease In: Slows down the value changes entering a keyframe.
  • Ease Out: Gradually accelerates the value changes leaving a keyframe.


Adjust Bezier handles

  1. Display the Bezier keyframe you want to adjust.
  2. Select the the Selection tool or the Pen tool.
  3. To adjust the slope of the curve, drag the Bezier handle up or down. Moving the handle up accelerates the changes and moving the handle down decelerates the changes.
  4. To adjust the range of the curve’s influence, drag the Bezier handle to the left or right.

Velocity Graph

In the Effect Controls panel, you can use the Velocity graph to adjust motion or the rate of change for a value just before and just after a keyframe. Such adjustments can simulate real-world motion. For example, you can change the motion of a clip so that it slows down just before a keyframe and then speeds up just after the keyframe. You can control the values approaching and leaving a keyframe together, or you can control each value separately.


Masks

  • All effects except Warp Stabilizer have built in masks
  1. Drag Gaussian Blur to a clip.
  2. Look at the clip in Effect Controls
  3. You can create an ellipse, 4-point polygon or free draw bezier mask.
  4. Add a mask to the clip.
  5. Turn up the Gaussian Blur effect
  6. Only the masked are will be blurred.
  7. Click the Inverted check box to invert the mask

Motion Tracking

  1. Go to the first frame off the motion
  2. Add mask where needed.
  3. Click the Track Selected Mask Forward button
  4. Wait

Editing Mask Paths

  1. Select theMask and zoom in the keyframes.
  2. Use Go to Next Keyframe button to get to the keyframe to edit.
  3. Move the Mask as needed.
  4. Repeat


Adding Ultra Key

  1. Put the "green screen clip" on video track 2
  2. Put the background clip on video track 1
  3. Add Ultra Key to the "green screen clip"
  4. Select the "green screen clip" and go to Effect Controls
  5. Click the Eyedropper and hold the command key.
  6. Click the color to key out with average lighting.
  7. Set the Setting to Aggressive

Adjusting Settings

  1. Set output to Alpha Channel to view the mask.
  2. Under Matte Generation adjust the Pedestal
  3. Under Matte Cleanup adjust Choke and Soften
  4. Set output back to Composite to view the effect.

Adding Masks

  1. Add a mask to the Opacity of the keyed clip
  2. Adjust the size of the mask
  3. Adjust the Mask Feather to have a smother transition.


  • Lumertri Color is the color correcting effect in Premiere Pro
  • Lumetri Scopes are various graphic meters for assisting in color correction.

Set Up

  • Choose the Color workspace or the MML-Dual Screen workspace.
  • Make sure you can see the Lumertri Color and Lumertri Scopes panels at the same time.
  • When the the Lumertri Color panel is open Selection Follows Playhead is tuned on.
    • This makes it so that the Lumertri Color and Lumertri Scopes panels always show the clip under the playhead.

Basics Controls

  • The check box at the top right of each section can be used to bypass the entire section.
  • Double click on a slider to rest that value to it's default.
  • To add a mask go to the Effects Controls panel and add a mask to Lumetri Color.
  • Color Wheels: Drag around the circle to choose a color. Drag to the edge to increase the intensity. Double click to rest to the default.

Saving Presets

  • At the top of the Lumetri panel click the 3 horizontal lines.
  • Use Export .look to export a LUT.
    • This can be imported in the Creative section
  • Use Save Preset to export a preset.
    • This can be used to add a Lumetri Effect to a clip with all of the settings editable.

Lumetri Color Sections

  • Basic Correction: technical corrections to exposures
  • Creative: apply and adjust looks
  • Curves: refine the look using RGB Curves and the Hue Saturation Curve
  • Color Wheels: adjust shadows mid-tones and highlights
  • HSL Secondary: isolate a color to apply secondary correction
  • Vignette: apply a vignette

Basic Correction

White Balance
  • Set White Balance by using the Eyedropper tool to click on a white object in clip.
  • Use the Temperature slider to adjust color temperature.
    • Left for cooler and right for warmer.
  • The Tint slider compensates for a green or magenta tint.
    • Left to add green and right to add magenta.
Tone
  • Exposure: Sets the brightness of the clip. right expands highlights and left expands shadows.
  • Contrast: Adjusts midtones.
  • Highlights: Adjusts bright areas
  • Shadows: Adjusts dark areas.
  • Whites: Adjusts white clipping
  • Blacks: Adjust black clipping
  • Reset: resets all controls to the 0.
  • Auto: Click to automatically maximize the tonal scale and minimize highlight and shadow clipping.
    • This can be useful to start from but do not rely on it.
  • Saturation: Adjusts the saturation levels.

Creative

This section is used to apply and modify Looks.

Looks are presets designed to give the video a certain film look. You can use the included Looks, load other Looks or make custom Looks with Speedgrade.

  • Look: Use the pull down menu to choose a Look. Or click on the image to browse thru the Looks. Double click to apply it.
  • Intensity: Adjusts the intensity of the Look.
  • Faded Film: Applies a faded film effect.
  • Sharpen: Adjusts the edge definition. Too much can make the video look unnatural.
  • Vibrance: changes lower saturated colors with less effect on the higher saturation colors. Also prevents skin tones from being over saturated.
  • Saturation: Adjusts saturation of all colors equally.
  • Tint Balance: Adjust the tint of the shadows and highlights.

Curves

Use to refine the clip with RGB Curves and the Hue Saturation Curve.

RGB Curves
  • The white luma curve controls all 3 colors simultaneously.
  • Click on the red, green or blue to adjust a color independently
  • Click to add a point. Command click to delete a point.
  • Dragging up or down lighten or darkens the clip.
  • Dragging left or right increases or decrease contrast.
Hue Saturation Curves
  • Drag the white wheel outward to saturate or inward to desaturate.
  • Click on the wheel to add edit points.
  • Drag the to modify specific hues.
  • Or click one of the small circles to select a preset color range.

Color Wheels

Adjust shadows, midtones, and highlights using color wheels for more precise color adjustments.

  • Use the 3 wheels to adjust shadows, midtone and highlights.
  • Use the sliders to to increase or decrease the setting.

HSL Secondary

The hue, saturation and luma secondary section is used to isolate a color or luma key and apply a secondary color correction to it.

Control for Setting the Key
  • The H, S and L sections all have check boxes to bypass the setting
  • The top triangle controls the range of the setting.
  • The bottom triangle adds a feathering to the range.
  • Click on the gray bar to drag the range.
  • When a setting is being adjusted the display switches to the mask.
  • Click the check box next to the mask controls to turn the mask on.
  • The mask has three different display settings.
Set the Key
  1. Use one of the preset colors or use the eyedropper to pick the target color
  2. Press the command key with the eyedropper to select a 5 x 5 grid of pixels.
  3. Adjust the range and feathering of the hue.
  4. Fine tune the mask by adjusting the saturation and luma setting.
  5. Use Denoise and Blur as needed to refine the mask.
Adjust the Color
  • Use the little circles at the top to choose between one or three color wheels.
  • Each color wheel con be used to modify the selected color.
  • Each wheel has a luma adjustment slider.
  • Use the Temperature slider to adjust color temperature.
    • Left for cooler and right for warmer.
  • The Tint slider compensates for a green or magenta tint.
    • Left to add green and right to add magenta.
  • Contrast: Adjusts midtones.
  • Sharpen: Sharpens or blurs the selected color.
  • Saturation: Adjusts the saturation

Vigenette

Apply a vignette to achieve a look that is faded out at the edges, and bright at the center. 

Titles

  • Premiere has a new way of creating Titles.
  • The old way of creating titles describe below is now called Legacy Titles

Creating Titles

  • To create a new legacy title go to File > New > Legacy Title ...
  • In the New Title dialog the Video Settings should default to match the Project Settings
  • Name the title and click OK.
  • Click the Roll/Crawl Options button to choose Still, Roll, Crawl Left and Crawl Right.
  • Click the New Title Based on Current Title button to duplicate a title.



Duplicating Titles

If a Title is duplicated in the Timeline by option dragging or by copy and paste it, the copy will be tied to the original. If one of the copies is modified they all will be modified.

There needs to be a separate Title clip in the Project panel for each unique Title.

  • In the Project panel right-click on a Title and select Duplicate or go to New Title > Based on Current Title
  • When the Title Designer panel is open click the New Title Based on Current Title button



Safe Margins

  • To enable or disable Safe Margins click horizontal lines to the right of the title name and select or deselect
    • Safe Title Margins
    • Safe Action Margins



Video Behind Titles

  • When a title is being edited but is not yet in the timeline It can be previewed with or without video in the background.
    • Click the Show Background Video button in the top of the Title panel to enable or disable the video.
    • To change which frame of video is displayed change the timecode value below the button or move the playhead in the Timeline.
  • When a title is in the Timeline.
    • It it is above another video track the titles will appear over the video track below.
    • It it is not above any video tracks the titles will appear over black.



Text Tools

Type Tool

  • With the Type Tool just click in the title panel and start typing.
  • Use the Selection tool to position the title.
  • Use the 'Selection tool to resize the text box.
    • This will change the size of the text.

Area Type Tool

  • Click and drag in the title panel and to create a text box.
    • The text box determines where text will appear.
    • Changing the size of the box does not affect the text size.

Text Formatting

In the top of the Title panel and in the Title Properties panel there are text formatting tools.

  • Font type
  • Bold, underline, italics.
  • Font size (in scan lines)
  • Kerning
  • Left, center, right justification.


Color

In Title Properties the Fill setting determines the color.

  • Click the Color box to open the color picker.
  • Click the Eyedropper tool and select a color from a frame of video
    • The titles color will change as the mouse is moved. Click to set the color.
Outlines

To add an outline to a title you need to add and Outer Stroke.

A slight back outline can help light text stick out over video.

  1. In Title Properties go to Strokes - Outer Stroke and click Add.
  2. Set the Type to Edge.
  3. Adjust the Size as desired.
  4. Set FIll Type to Solid
  5. Set the Color.